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1 Background 

The intent of this document is to clearly define the steps required to install the plugins 

required to run the Western Australian Department of Water (DoW) Farm Dam Plugins used 

to drive the Planning and Allocation Tool. The underlying hydrological modelling system is 

eWater’s Source Integrated Modelling System (more information about the Source platform 

is available at www.ewater.com.au/products/ewater-source). The Planning and Allocation 

Tool (P&AT) was developed by Sinclair Knight Merz (SKM) and the Western Australian 

Department of Water (DoW), with support from the National Water Commission (NWC). The 

tool simulates the impact of farm dams on rivers and applies environmental engineering 

principles to characterise the reliability of water from farm dams to agricultural land. The tool 

is a decision support system designed to support planning and licensing decision making 

about self-supply irrigation in south-west Western Australia.  

The P&AT models represent each farm dam as storages within a larger network of 

distributed, hydrologically connected farm dams. For each dam, Source conducts a daily 

water balance including inflows, rainfall, evaporation, seepage, water usage (demand) and 

overflow (spill) components (Figure 1-1). This means that, for each day, each of these water 

balance components is accounted for in Source for every farm dam modelled. 

 

 

 

 

 

 

 

 

 

 

 

Figure 1-1: Water balance of a farm dam, represented in the Source P&AT 

 

For more information on the initial P&AT models, SKM has produced a series of project 

reports that are available upon request from the Department of Water. These reports include: 

- User requirements report (SKM, 2012) 

- Systems design report for the planning component of the tool (SKM, 2012c) 

- Model implementation report (SKM, 2012d) 

- User manual (SKM, 2012e) 
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2 System requirements 

The minimum hardware requirements for user’s PCs are listed in Table 1-1. These 

requirements are a combination of the requirements for ArcGIS 10.0 and for eWater Source. 
 

Table 2-1: System requirements for the Planning and Allocation Tool 

 

 

 

 

 

 

 

 

 

 

Extra notes on the system requirements include: 

• Computer administration rights are required to install the software. Running the 

software does not require administration rights by the user.  

• The software is compatible with Windows XP (with service pack 3) or Windows 7; 32-

bit or 64-bit versions (Note, the Software is not compatible with Windows Vista 

operating system). 

• Source software can only be run locally and cannot be installed on a server or 

accessed remotely. 

• Access to the internet is desirable for easy registration of the Source software. 

 

 

 

 

 

CPU Speed 2.2 GHz minimum or higher; Hyper-threading (HHT) or Multi-core recommended

Processor Intel Pentium 4, Intel Core Duo, or Xeon Processors; SSE2 (or greater)

Memory/RAM 2 GB or higher

Display Properties 24 bit color depth

Screen Resolution 1024 x 768 recommended or higher at Normal size (96dpi)

Swap Space Determined by the operating system, 500 MB minimum. The system will  run more 

efficiently with at least 8 GB of free hard drive space.

Disk Space 2.4 GB

Video/Graphics Adapter 64 MB RAM minimum, 256 MB RAM or higher recommended.  NVIDIA, ATI and INTEL 

chipsets supported24 bit capable graphics accelerator

OpenGL version 2.0 runtime or higher is required, and Shader Model 3.0 or higher is 

recommended.  Be sure to use the latest available driver.

Networking Hardware Simple TCP/IP, Network Card or Microsoft Loopback Adapter is required for the License 

Manager.

Prerequisite software .NET Framework 3.5 and .NET Framework 3.5 service pack

ESRI ArcMap l icense (no extra extensions required)

eWater Source IMS (Version 3.2 or greater)
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3 Installation instructions 

• Make sure the latest version of eWater Source is installed on the user’s PC. The 

Department has unlimited licenses under the license agreement for the Source 

software. The license agreement can be obtained from ISB. 

• Copy the files NetworkBuilder.dll directly into the same folder as the Source 

program (this will generally be C:\Program Files\Source 3.#.#.# - where # will change 

depending on the latest version of Source). 

• Copy the files FarmDamNodeModel.dll, ObservationPointNodeModel.dll, 

FDNetworkTools.dll  into the Source Plugins folder (this will generally be 

C:\Program Files\Source 3.#.#.#\Plugins) 

• Open Source - go to Tools > Plugin manager 

• Navigate to the following plugins (in the Source Plugins folder) 

o FarmDamNodeModel.dll 

o ObservationPointNodeModel.dll 

o FDNetworkTools.dll 

• Due to cross-referencing, plugins should be added one at a time in the order above. 

This means add one, click ok, then add another. There is no need to close Source in 

between. 

• Close Source 
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4 Using the Plugins 

4.1 Building a new model 

A model similar to the P&AT models can be created via the New Scenario button (Figure  4-

1).   

 

 

Figure 4-1: New Scenario button menu options 

 

If no project is open, you will be prompted to create a new one.  If a project is open the Farm 

Dams model will be appended to this project as a new scenario.   

4.2 Terrain analysis 

The first main step is terrain analysis.  There are three inputs to this step: 

• Digital Elevation Model (DEM), as an ascii grid (refer to the Source manual for 

format details).  This provides information on the terrain of the catchment.  There is 

no maximum cell size, but coarse grids may lead to unrealistic results.  It is 

recommended to use DEMs of resolution 20m or finer, preferably less than 10m.  

Note that it is preferable to ‘burn’ a stream network into your DEM before use in the 

plugin. This ensures that observation points and farm dams that are located on 

streamlines are connected spatially when the tool is run (as errors in the DEM can 

cause incorrect linkages in the output network file). 

• Farm dam polygons, as a shapefile, in the same projection as the DEM.  This tells 

Source the location and extent of each dam.  The shape file attribute table must have 

a column containing a unique ID for each dam, and a further column containing the 
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volume of each dam.  Note that the unique ID must be a text field, or the tool will 

crash. 

• Observation points (optional).  These may be used to: 

o Report on the flow that occurs at locations of interest; and / or 

o Improve the appearance of the model by forcing links to follow drainage lines. 

To run the terrain analysis, click on the respective buttons to load each input and then press 

Run.  The terrain analysis (Figure 4-2) takes between 1 hour and 1 day depending on the 

size of the catchment and the number of dams.  If your catchment is too large, the program 

may present an error window.  If this occurs, seek out a more powerful computer, or split up 

your catchment into smaller pieces and re-run Source.   

 

 

  

Figure 4-2: Farm dam terrain analysis in Source, before and after.  The legends are 
expanded for interpretation. 

 

Once the terrain analysis is complete, the Next button will be available.  The results are 

loaded into a table (FigureFigure 4-3).  Some fields are fixed (ID, Easting, Northing) but you 

may edit the values of the remaining fields and this will over-ride the results of the terrain 

analysis.   

Fill in the initial storage field to specify how full the dams are at the start of the model run.  

For the DoW PAT models, which started on 1st January, a value of 80% was used.   

Choose the surface area model to assume.  Surface area varies with volume means that 

rainfall, evaporation and seepage will be applied to a surface area that is calculated on-the-
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fly for each time-step based on how full the farm dam is.  Constant surface area adopts the 

maximum surface area regardless of how full the dam is on a given day.   

 

 
Figure 4-3: Dam Information tab of the table for entering farm dam details 
 

Assigning time-series inputs 

Next, you need to assign time-series inputs using the tabs at the top of the screen.  There 

are five inputs to assign, as described in the following sections.   

Streamflows  

Description: Streamflows at the catchment outlet should be entered if available. This can be 

an estimate of ‘no-dams-flow’, or it can be derived from rainfall-runoff modelling.  

More than one series may be entered, and you can indicate which time-series is relevant to 

each dam.  This means that you can assign a different time-series for each tributary in your 

catchment, provided you know which dams are in which tributary.   
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Figure 4-4: Streamflows tab of the table for entering farm dam details  
 

A non-linear flow factor field is also provided.  This governs how the flow is split up between 

the dams.  In the 17 P&AT models, a value of 1.0 was used which means that flow is split up 

linearly according to the catchment area of each dam.  For more information about the non-

linear flow factor, please refer to the STEDI manual (SKM, 2011).   

What to do:  

• Click ‘add from file’ and navigate to a pre-existing time-series file (in a Source-friendly 

format such as csv);  

• In the Reference Series table, specify the factor Z to use with this time-series;  

• In the Reference Series table, enter the catchment area.  If your time-series input is 

based on a gauge, enter the catchment area of the gauge.    

• Use the Apply selected time-series to > All farm dams option, if required, otherwise 

select a sub-set of the dams and use the Selected farm dams option.  The Scale 

Factor field will be automatically populated by this action, but can be manually 

changed as required.   

Please note that it is also possible to cross-reference a different scenario (for example, a 

rainfall runoff model) for input into a farm dams model. 
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Seepage 

Description: Seepage can be entered as a constant rate in mm/day, or as a time-series in 

mm/day.  The rate is applied to the surface area model chosen in the Settings box of the 

Dam Information tab.  As mentioned above, Surface area varies with volume means that it is 

applied to a surface area that is calculated on-the-fly for each time=step based on how full 

the farm dam is, whereas Constant surface area adopts the maximum surface area 

regardless of how full the dam is on a given day.   

What to do:  

• At bottom right, choose between Constant rate of seepage and Seepage time-series;  

• If Constant rate of seepage, type a rate in the first row, double click the number, and 

choose between Copy Value to All Rows or Copy Value to Checked Rows (Figure); 

• If Seepage time series, add the series the same way as for stream-flows.   

 

 

Figure 4-5: Seepage tab of the table for entering farm dam details 
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Demands 

Description: Demand is the water removed from a dam for on-farm use.  Two aspects of 

demand must be specified, namely magnitude and pattern.   Demand magnitude is set via 

the demand factor, which is the ratio of average annual usage to dam volume.  Demand 

pattern is set via an input time-series.  It does not matter what the unit of the input time-

series is; only the pattern is used.   

What to do: 

• Add a time-series to the Reference Time-series table in the same way as for 

streamflows;  

• Specify the demand factor to use with this time-series; 

• Choose between the All farm dams option and the Selected farm dams option, and 

click Apply.   

 

 

Figure 4-5: Demands tab of the table for entering farm dam details 
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Rainfall / Evaporation 

Description: Rainfall and evaporation are each entered as a time-series, in mm/day.  This 

series is then multiplied by the surface area of the dam.  The surface area is defined in the 

same way as for seepage.  As with the other time-series inputs, it is possible to enter one 

series and apply to all the dams, or different series for different groups of dams.   

What to do: 

• Add a time-series to the Reference Time-series table in the same way as for 

streamflows;  

• Choose between the All farm dams option and the Selected farm dams option, and 

click Apply.   

 

 

Figure 4-7: Rainfall tab of the table for entering farm dam details 
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4.3 Finalising and saving a model 

Once you have entered all the inputs listed above, click Finish.  The model itself will then be 

created based on the tabulated inputs.  In Source models, each dam and observation point is 

represented by a node, and the nodes are joined together by links that indicate how water 

flows from one feature to the next.   

The best option for viewing the model is the Geographic Editor tab (Figure 4-8) which allows 

spatial layers such as the farm dam polygons to be overlaid on the model nodes and links.  

Press the Save icon to save your model.   

 

 

Figure 4-8: Completed model with farm dam polygons overlaid.   
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4.4 Running a model 

All Source models need to be configured prior to running.  For farm dams models, this simply 

involves specifying the modelling period (Figure 4-9).  Once configured, the Run button 

becomes available.   

The model run time varies depending on the number of farm dams, and the host computer.  

Over the standard period, the model typically runs in around 2 seconds per farm dam.   

 

Figure 4-9: Configuring a Source farm dams model. 

4.5 Interpreting results 

There are two broad sets of options for viewing and interpreting results: the standard Source 

options, accessed via the Recording Manager; and the custom-built Reliability Tool.   

Recording Manager 

The Recording Manager allows viewing of time-series such as farm dam inflow, outflow, 

storage and demand.  The Recording Manager is a standard Source feature, and so only 

brief notes are provided here.  A detailed description of the Recording Manager is provided in 

the Source User Manual, available within the program via the Help > User Guide menu.   

In order to plot time-series in the Recording Manager, you need to switch them to ‘record’ in 

the Parameters window.  This must be done before pressing Configure or Run.  Do this by:  

• In the Hierarchy window, navigate to the model element you wish to record.   

• To record for all dams, select Scenario > Node > Onstream Farm Dam (Error! 

Reference source not found.).   

• For a single farm dam, expand the above and choose an individual dam.   

• In the Parameters window, right click on the required parameter and press Record 

All.   

Due to inherent Source defaults, there is some redundancy in parameters.  Table 4-2 shows 

the names to choose for some common farm-dam related parameters.   
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Figure 4-10: Source hierarchy and parameters windows 

Table 4-2: Common parameters to record for farm dams 

Description Parameter name 

Farm dam storage, in ML Storage Record 

Inflows into a farm dam, in ML/day Actual inflow 

Outflows due to a dam spilling, in ML/day Dam Spill 

Demand removed from a farm dam, in  ML/day Actual demand volume 

Rainfall, evaporation, or seepage, in ML/day Actual Rainfall, Actual Evaporation,  

or Actual Seepage. 

 

After the model has run, press the Recording Manager button (located underneath the Edit 

menu).  This brings up the Recording Manager window (Error! Reference source not 

found.a), which lists the parameters that were recorded.  Click View Time Series to plot, 
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tabulate or view basic statistics for a recorded parameter (Error! Reference source not 

found.b).   

 

 

 

Figure 4-11: (a) Recording Manager (top); (b) Example plotted storage trace 
(bottom).    

Reliability Tool 

The Reliability Tool is a custom built interface that plots reliability curves according to the 

specifications chosen by DoW to describe farm dam reliability in the South West.  It also 

provides maps of the farm dams shaded according to their reliability.   
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Before using the Reliability Tool, you need to run your model and record two things for each 

dam: dam capacity and storage record.  The Reliability Tool ( Figure) is accessed via 

Tools > Plugins > Farm Dam Modelling Tools > Reliability Analysis, and requires 

specification of:  

1. Time period: for example, if you wish for the analysis to be based only on the drier 

post-2000 period, select 01/01/2000 as your start date.  For the full period, use the 

default dates.   

2. Representative storage: the default is June-November peak.  This means that if the 

dam fills up at any time between June and November inclusive, this will be plotted as 

100%; otherwise the maximum storage attained during this time will be reported.  The 

alternative is to choose a fixed date to report (eg 1st December every year).  

3. Available runs: if you have run the model a number of times, select which run to 

use. 

4. Farm dams: select one or more farm dams to plot. 

5. Farm dam shapefile: Navigate to a polygon shapefile of the dams.  This is only 

required if you wish to use the mapping facility.  Please note that if a dam exists in the 

model but not in the shapefile, it will be absent from the map.   

6. Once you have specified the above details, click Analyse.  Source will plot the 

reliability curve for the dam(s) you have specified, and provide a map of farm dams if 

a shapefile has been supplied.  Please note that there have been ongoing issues 

with Source plotting and mapping features that are outside the control of SKM or 

DoW.  These features are generally correct, but please refer to the Table tab for the 

exact values.   

Reliability curves – what do they mean? 

A higher value on the reliability curve means the dam is more reliable, and a lower value 

means the dam is less reliable.  If most of the line is at y = 100% this means the dam fills in 

most years (Figure 4-12).  If only half of the line is at y = 100%, this means the dam only fills 

in half of all years.  The lowest y value of the line corresponds to the year with lowest storage 

in the model run.  For example, if the lowest value is 20%, this means that the maximum dam 

storage during the months of June to November of the year that had the lowest storage in the 

model run, was 20%.   

In cases where a new dam has been added, the reliability curve for the new dam will be 

plotted in blue (Figure 4-13) and the reliability curve for the next dam downstream will be 

plotted as a red solid line for the ‘before’ case and a red dotted line for the ‘after’ case.  Thus, 

the area between the red solid line and the red dotted line represents a reduction in reliability 

due to the new dam intercepting water.   
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Figure 4-12: Examples of reliability curves 

 
 

Figure 4-13: Reliability tool interface and plotted output 
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Reliability maps – what do they mean? 

The dams in the map are colour coded according to their reliability.  For each dam, Source 

identifies the number of years in 100 that the dam fills up, and this is the basis for the colour 

coding.  For example, for the dam in Figure 4-14 the mapped value would be ~50%.   

 

 

 Figure 4-14: Reliability tool interface and plotted output 
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4.6 Making changes to an existing model 

There are two ways to make changes to an existing model: 

• To make changes to multiple dams at once: The Tools > Plugins > Farm Dam 

Modelling Tools > Network Editor menu option leads to the same interface as 

described for model setup, with a few minor changes. All time-series inputs can be 

edited in this table. 

• To make changes to individual dams: The easiest way is to double click the dam 

node itself.  This brings up feature editor that displays all inputs for a given farm dam 

(Figure ).   

 

 

Figure 4-15: Farm dam feature editor 

 

Adding a farm dam 

To add a farm dam, access the Network Editor as per the instructions above.  There is an 

additional panel (Add a dam) at the left hand side of the Dam Information tab (Figure 4-15).  

Specify:  

1. A name for the new dam;  

2. The next dam downstream (field Upstream of ) and any upstream dam(s) 

(Downstream of );  

3. Dam volume, in ML;  

4. A nearby dam to copy over the other modelling inputs (rainfall/evaporation, seepage, 

demand);  
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5. The catchment area, subject to logical constraints from (b) above; and 

6. The coordinates (optional).  If you do not edit these, the dam will be placed 

equidistant between upstream and downstream dams.   

 

 

Figure 4-16: Extra panels in the Network Editor when not in ‘model creation’ mode 

Changing the total volume of dams in a catchment 

To change the total volume of dams in a catchment, you can either add dams singly as per 

the previous section, or you can use the Factor Dam Volumes panel, located above the Add 

a Dam panel from the previous section (Figure 4-16).  Specify a factor and the dams to be 

factored, and press Apply.  For example, if you enter 1.1, selected dams will increase in 

volume by 10%.   

Notes about scenarios and projects 

In general, it is recommended to create a copy of your model before making changes, by 

either:  

• Copying and pasting the file in Windows Explorer; or 

• Creating a new scenario in your Source model.  This means that the various 

scenarios can be kept together in the same file.  To copy your existing model into a 
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new scenario, select the existing scenario in the Project Hierarchy window and press 

the Copy Scenario button.   

• Note that it is also possible to build a new model from scratch, as a scenario in an 

existing model.  To do this, open the existing model and then follow the instructions 

above. 

4.7 Linking the P&AT models with other Source 
functionality 

The P&AT farm dams models can be linked with many other features of Source functionality, 

as described below.  Please note that, in most cases, these potential links have not yet been 

tested in practice.  Therefore, please take care to thoroughly review the results. 

Linking with geographic models (including rainfall runoff models) 

It is possible to cross reference the results of geographic (Source Catchments) models for 

use as inputs in farm dams models.  For example, a common enquiry has been whether the 

farm dam inflows can be linked to a rainfall runoff model rather than gauged inflows.  To do 

this: 

• Set up your rainfall runoff model within a geographic (Source Catchments) scenario, 

following the instructions in the Source manual (Help > User Guide);  

• Run you rainfall runoff model, ensuring you set to ‘record’ the flow series you wish to 

use;  

• Start a new scenario within the same project for your farm dam model.  Do this by 

clicking on the New Scenario button and selecting Farm Dam model;  

• Create your farm dam model as per the instructions in Section 4.1;  

• When you reach the Streamflows tab (Figure ), click Add from Scenario rather than 

Add from File.  Then, select the scenario and the recorded time-series you wish to 

use.   

Linking with Source Rivers models 

Source Rivers models represent the operations of river infrastructure such as weirs, dams 

and channels.  Unlike geographic models, these models are generally built via ‘drag-and-

drop’ from the node palette.  The farm dam nodes and observation point nodes can be 

dragged and dropped into Source Rivers models alongside other Source node types.  

However, doing so may compromise some aspects of functionality, and this has not yet been 

tested.  eWater staff (Geoff Davis, pers. comms.) have indicated that it is likely that all 

functionality will work, provided that the farm dam and observation point nodes is upstream 

of the Source Rivers nodes.  Given the significant uncertainty, we recommend that farm 

dams models and Source Rivers models be separated into different scenarios within the 

same project, and cross referenced as described above.   
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4.8 New versions of Source 

As at August 2013, the current versions of the plugins were developed with Source 3.3.0.232  

Although an update of the plugins to a new version is planned, the timeline of this is 

uncertain.   

Plugins tested with one version are not guaranteed to work with subsequent versions.   

4.9 Note on Source farm dam functionality 

There is potential for confusion since Source has an in-built farm dams processor included 

as standard.  For clarification: 

• The in-built farm dams processor cannot represent farm dams individually or link farm 

dams into a network.  Rather, farm dams are inputted as a distribution on volume 

(similar to the program TEDI but lacking the advanced functionality of the program 

STEDI);    

• This functionality provides a simple way of representing farm dams in models where 

the focus is on other features (e.g. large reservoirs).  However, it is incapable of 

fulfilling P&AT requirements such as outputs for individual dams;  

• The capability described further in this report was developed by SKM specifically for 

the P&AT project.   
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5 Frequently asked questions 

This section contains a number of frequently asked questions about the P&AT.   

In many cases, the questions are answered in the text, and the answer simply contains a 

reference to the relevant section.   

 

Q: Are the P&AT models ‘Source Catchments’ (Geographic) models or ‘Source Rivers’ 

(Schematic) models? 

A: The P&AT models combine aspects of both model types, as required to represent the 

unique situation in SWWA.  The models can be viewed in Source via either option, but it is 

recommended to use the Geographic Editor as standard.   

 

Q: What is the relationship between the P&AT models and the Farm Dams Filter Model 

in the Source Geographic Wizard? 

A: Refer to Section 4.9.. 

 

Q: Can the P&AT models be combined with other aspects of Source? 

A: Yes, in most cases.  Refer to Section 4.7. 

 

Easting / Northing: as per the farm dam naming system.   

 

Q: What do the different plugins do? 

A: In summary: 

• FarmDamNodeModel.dll describes the characteristics of the farm dam node model;  

• ObservationPointNodeModel.dll describes the characteristics of the observation point 

node model;  

• NetworkBuilder.dll contains the majority of the remaining code, including the ability to 

build models and interpret them via reliability curves;  

• FDNetworkTools.dll contains code to alter features in NetworkBuilder.dll according to 

the context.   

 

Q: Do the farm dams modules work with the water quality aspects of Source? 

A: It is unlikely, but this has not been tested.  The plugins were not specifically written to work 

with the water quality modules.  It is possible to investigate this further if required, and it is 

likely that a ‘farm dams water quality’ module could be written.   
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