This section provides an overview of each menu, sub-menu and toolbar command available in the Source main screen. It also acts as a good reference point when you become familiar with Source.

 

Note: The Results Manager opens in a separate window after a scenario run. Refer to the following associated menu options and toolbars:

Table 1. Menus
MenuDescription
Menu barSimilar to the high-level standard Windows menu bar, this bar allows you to access various components of Source.
File menuProvides high-level management of files, scenarios and projects, such as the ability to save, close and open files.
Edit menuProvides access to various components, such as ownership, resource assessment and additional tools (for example, the Feature Table and Scenario Input Sets).
View menuControls visibility of various panels, such as the Project Explorer or Log Reporter.
Run menuProvides the ability to run scenarios.
Tools menuProvides access to various tools and plugins.
Help menuProvides links to useful materials, such as documentation, training and the eWater website.
Results Manager

Comprised of the following menus that allow you to manage results analysis:

  • File – Load results files and time series, save and load configuration files;
  • Options access Transforms; and
  • Help Provides links to documentation, feedback and a list of the keyboard shortcuts.
Table 2. Source toolbars
ToolbarDescriptionLocation in Source
ChartAllows you to manage and work with charts.Results Manager
Data SourcesAllows you to manage and work with time series data.Data Sources Explorer
Date RangesAllows you to manage and work with date ranges.Function Editor
Results ManagerAllows you to manage, analyse and view resultsResults Manager
FileProvides high-level management of projects and scenarios.Main screen
Function EditorAllows you to work with functions.Function Editor
Function managerProvides high-level management of functions.Function Manager
Geographic EditorAllows you to work with catchments scenarios.Geographic Editor
Scenario Input SetsAllows management of input sets (used when importing data).Scenario Input Sets
Layer ManagerProvides managements of layers used in the catchments scenarios.Layer Manager
MapsAllows management of a background map image with overlaid nodes of a schematic scenario.Maps
OrderingProvides access to the Ordering dialogs.Main screen
ProjectProvides shortcuts to various Source components.Main screen
Project ExplorerProvides high-level management of scenarios and projects.Project Explorer
Quick View

Quickly alter the view of your results.


Results Manager
Recording ManagerAllows you to manage scenario run results.Recording Manager
ScenarioProvides shortcuts to various Source components.Main screen
Schematic EditorAllows you to edit the display properties of the Schematic Editor and components shown within it.Schematic Editor
SimulationAllows you to undertake a scenario run.Main screen
StatisticsAllows you to edit the statistical view of results.Charting tool
Text managementA generic toolbar used for management of text input.Forms part of the Functions and Scenario Input Sets toolbars
TransformsAllows management of transforms.Results Manager

Menus

The menu bar for Source is shown in Figure 1 and is like the standard Windows™ menu bar. This section outlines the function of each menu item.

Figure 1. Menu bar


Figure 2. File menu

File » New » Project…

Creates a new, empty project. Opens the Create a project dialog where you can name your project, provide a brief description of its purpose and choose the type of scenario you wish to create. See Projects and scenarios - Projects.

File » New » Scenario…

Adds a new, empty scenario to the current project. Opens the Create a Scenario dialog that offers a choice of the Geographic wizard or creating a Schematic scenario. Select the type that is appropriate to your needs. Name your scenario and provide a brief description of its purpose and click OK. This command is a synonym for New Scenario (by menu) on the Project Explorer toolbar See Projects and scenarios - Scenarios

In the absence of an open project, implies creating a new project.

File » Open…

Opens an existing project using the standard open file dialog. Synonym for Open Project on the File toolbar. Source projects use the ".rsproj" extension.

File » Close Project

Closes the current project. Prompts to save your work. Click Yes to save your work, No to discard any changes, or Cancel to return to Source.

File » Save

Saves the current project, overwriting the existing file. Synonym for Save Project on the File toolbar. Implies File » Save As… if the project has never been saved.

File » Save As…

Opens a standard save dialog which allows you to:

Source projects use the ".rsproj" extension.

File » Print…

This command is currently disabled. However, the Print buttons on the Schematic Editor and Geographic Editor toolbars may be used to print scenarios.

This command is currently disabled. However, the Print buttons on the Schematic Editor and Geographic Editor toolbars may be used to print scenarios. Clicking that button also provides a preview.

Opens the Import Scenario dialog where you can import scenarios from different projects. See Import and export of data - Importing scenarios.

File » [recent documents]

This area contains a list of recently saved projects. You can re-open any project by choosing its name from the list in this area.

Note: This assumes that the associated project file has not been either moved from the location where it was saved, or renamed, or deleted from your hard disk.

File » Exit…

Quits Source. You are asked to confirm your intention and reminded to save any unsaved work.


Figure 3. Edit menu

Opens the Constituents Configuration dialog where you can define constituents. See Constituents - Configuring constituents.

Opens the Edit Scenario Configuration – Name Functional Units dialog where you can inspect the list of existing functional units. You can also use this dialog to add new functional units or delete functional units that are no longer required. This dialog is equivalent to step 4 of the Geographic Wizard and is only available when a catchments scenario is active.

Edit » Functional Units » Assign Area Via Raster…

Opens the Set Functional Unit Area Via Raster dialog where you can associate sub-catchments with functional units using a raster. This dialog is only available when a catchments scenario is active. See Functional units - Using a raster.

Edit » Functional Units » Assign Area Manually…

Opens the Functional Unit Area Configuration dialog where you can manually associate sub-catchments with functional units. This dialog is only available when a catchments scenario is active. See Functional units - Manual assignment.

Opens the Edit Scenario Configuration – Catchment Model Assignment (optional) dialog where you can assign constituent models at the whole catchment level. This dialog is only available when a catchments scenario is active, and also requires a plugin.

Opens the Restriction Curves Explorer dialog where you can edit restriction curves. See Restriction Curves.

Opens the Scenario Options dialog where you can set preferences that affect the selected scenario. The following options are available:

See Scenario Options

Opens the Project Options dialog where you can set preferences that affect the open project. The following options are available:

See Project Options.

 Edit » Ownership…

Opens the Ownership Setup dialog where you can manage ownership in a scenario. See Ownership.

Edit » Resource Assessment…

Opens the Resource Assessment Explorer dialog where you can configure Annual Accounting, Continuous Accounting and Continuous Sharing. This dialog is only available when a schematic scenario is active. See Resource assessment.

Edit » Ordering » Network Costs…

Opens the Configure Ordering Network Costs dialog, where you configure network costs for use with network linear programming ordering. Synonym for Network Costs… in the Ordering toolbar. See Network linear programming - Configuring optimisation.

Edit » Crop Parameters…

Opens the Crop Parameters dialog where you can configure crops for use at the water user node. See Configuring generic crop settings.

Opens the Function Editor dialog where you can edit functions. See Functions - Function Editor.

Opens the Link Cross Sections dialog where you can assign a physical cross-section for generating link rating curves. See Cross Section Editor

Opens the Constituent Model Configuration dialog where you can assign and manage the constituent generation, filter, instream processing and storage processing models for all constituents in the scenario. See Constituents - Constituent model configuration.

Opens the Rainfall Runoff Model Configuration dialog where you can assign and work with rainfall runoff models. This dialog is only available when a catchments scenario is active. See Rainfall runoff models.

Opens the Demand Constraints dialog where you can view all configured demand constraints. See Water user node - Demand constraints.

Opens the Feature Table dialog where you view parameters for each of the configured nodes in the scenario. See Feature Table.

Opens the Scenario Input Sets dialog where you can create and manage scenario input sets. See Scenario Input Sets.

Figure 4. View menu

Many of the commands in this menu control whether a window is visible on your screen. The commands act as toggles:

The commands remember the location of a window while it is hidden:

View » Project Explorer

Toggles whether the Project Explorer is visible on screen. Synonym for Project Explorer on the Project toolbar. See User Interface - Project Explorer.

View » Recording Manager

Toggles whether the Recording Manager is visible on screen. Synonym for Recording Manager on the Project toolbar. See Recording Manager.

View » Log Reporter

Toggles whether the Log Reporter is visible on screen. Synonym for Log Reporter on the Project toolbar. See Running Scenarios - Using the Log Reporter.

View » Data Sources

Toggles whether the Data Sources Explorer is visible on screen. Synonym for Data Sources on the Scenario toolbar. See Specifying data inputs - Data Sources Explorer.

Toggles whether the Function Manager is visible on screen. Synonym for Function Manager on the Scenario toolbar. See Functions - Function Manager.

Toggles whether the Geographic View is visible on screen. Synonym for Geographic Editor on the Scenario toolbar. See Geographic Editor.

View » Layer Manager

Toggles whether the Layer Manager is visible on screen. Synonym for Layer Manager on the Scenario toolbar. See User Interface - Layer Manager.

Toggles whether the Location Control is visible on screen. Synonym for Location Control on the Scenario toolbar. See Maps - Location Control.

Toggles whether the scenario map is visible on screen. Synonym for Map on the Scenario toolbar. See Maps.

View » Node Palette

Toggles whether the Node Palette is visible on screen. Synonym for Node Palette on the Scenario toolbar. See Nodes and Links.

View » Schematic Editor

Toggles whether the Schematic Editor tab is visible on screen. Synonym for Schematic Editor on the Scenario toolbar. See Schematic Editor.

View » Tabular Editor

Toggles whether the Tabular Editor tab is visible on screen. Synonym for Tabular Editor on the Scenario toolbar. See Tabular Editor.

View » Reset All Windows

Restores the default arrangement of Source windows. Requires an active scenario. Affects the Node Palette, and the Geographic, Schematic and Tabular editors. If an affected window is undocked, it will be re-docked. If an affected window was auto-hidden, that feature will be turned off. Any affected window that has been moved will be restored to its default location.

Opens the Audit Logs Viewer dialog. Right-click on a cell to copy either the selected entries or all entries to the clipboard.

View » Notes…

Opens the Notes dialog showing all 'post-it' type notes that have been added to items (eg. nodes, links, function) in the current scenario. See User Interface - About Notes.

Opens the Results Manager window where you can examine and analyse results. See Results Manager.

Opens the Execution Order window showing the order of node execution in the current scenario. See Running Scenarios - Execution order rules.


Figure 5. Run menu

Run » Configure…

Opens a configuration window where you can set parameters to control the run (eg. date range, scenario input sets). The configuration window shown depends on the analysis type selected in the Simulation toolbar. Synonym for Configure on the Simulation toolbar. See Configuring Scenarios and Forecasting and Operations.

Run » Run…

Performs the selected analysis. Synonym for Run on the Simulation toolbar. See Configuring Scenarios and Forecasting and Operations.


Figure 6. Tools menu

Tools » Analysis Windows » Map…

Displays a map of flows and constituent loads per sub-catchment See Catchment Map Results Analysis.

Tools » Analysis Windows » Data Unit Converter

Converts data from one unit type to another. See Analysis tools - Data unit converter

Launches the calibration wizard for catchments. Synonym for clicking Configure on the Simulation toolbar (or choosing Run » Configure…) when analysis type is set to Flow calibration analysis. See Calibration Wizard for catchments.

Opens the recordable element selection step of the calibration wizard for catchments. This panel should be treated as read-only. See Calibration Wizard for catchments - Select elements to record.

Opens the period definition step of the calibration wizard for catchments. This panel should be treated as read-only. See Calibration Wizard for catchments - Define calibration period.

Opens the metaparameter definition step of the calibration wizard for catchments. This panel should be treated as read-only. See Calibration Wizard for catchments - Defining metaparameters

Opens the optimisation function configuration step of the calibration wizard for catchments. This panel should be treated as read-only. See Calibration Wizard for catchments - Configure optimisation functions.

 Tools » Calibration » Result

Opens the optimisation results window. This window is populated by a run of the calibration wizard for catchments. See Calibration wizard for catchments - Inspecting calibration results.

Opens the Test runner window where you can run a regression test. See Regression testing - Running regression tests.

Tools » Regression Tests » Test Builder

Opens the Test Builder window where you can create a regression test. See Regression testing - Building regression tests.

Tools » Data Calculator Tool

Opens the Data Calculator window, where you can perform mathematical, statistical and reflected operations on raster or time series data. See Analysis tools - Data calculator

Opens the Data Modification Tool window, where you can edit raster or time series data depending on conditional statements that you can defineSee Analysis tools - Data modification tool.

Opens the Find dialog where you can search for nodes and links in the current open scenario. Synonym for Ctrl+F. See Nodes - Searching for nodes and links.

Opens the Chart window. 

Allows access to some of the plugins added using the Plugin Manager. See Plugins.

Tools » Plugin Manager

Opens the Plugin Manager dialog that allows you to add and remove plugins in Source. To add or edit plugins you need to close any open Source project. See Plugins - Working with the Plugin Manager.

 Tools » Application Settings…

Opens the Application Settings dialog. See Application settings.

Tools » River Operations…

Opens the River Operations dialog where you can manage forecasting for a scenario. See Forecasting and Operations.

Opens the Function Execution Order dialog showing the order in which functions are evaluated for each time of evaluation. See Functions - Debugging.

Turns on the Recording Manager.

Opens the Source Project Diff Tool window where you can find the differences between two scenarios. See Scenario Difference Tool.

Allows you to save scenario configuration details to a *.csv file. 

Opens the Climate Data Import Tool window where you can import climate data for a catchments scenario. See Climate data import tool.


Figure 7. Help menu

Launches your browser with a URL to the eWater Support page.

Launches your browser with a URL to the eWater Training page.

Help » Source Documentation

Launches your browser with a URL to the home page of this documentation. 

Launches your browser with a URL to the eWater Toolkit.     

Launches your browser with a URL to the page Australian Modelling Practice                                                                                                                                               

Launches your browser with a URL to the eWater support site (Uservoice).

Help » Splash Screen

Opens the Source splash screen (synonymous to opening Source for the first time). 

Launches your browser with a URL to the eWater website.

Opens the Toolkit login dialog where you enter your login credentials.

Opens a window containing product and license information.

 Result Manager Menus

The menu bar for Results Manager is shown in Figure #8. This section outlines the function of each menu item.

Figure 8. Results Manager menu bar.

Figure 9. Results Manager File menu

Loads all result files (*.res.csv) in the specified folder into Results Manager. Files in sub-folders are not loaded, nor are other time series. Synonym for Load a folder of Results Files (*.res.csv) on the Results Manager toolbar, and Ctrl+RSee Results Manager - Loading Results.

Loads any time series file type compatible with Source into Results Manager (refer to complete list of Data file formats). Multiple files can be selected and imported at once. Synonym for Load a times series on the Results Manager toolbar, and Ctrl+OSee Results Manager - Loading Results.

Saves the current configuration of Results Manager to a configuration file (*.dora). Synonym for Save configuration on the Results Manager toolbar, and Ctrl+S. See Results Manager - Configurations.

Loads a previously saved configuration file (*.dora) into Results Manager. Synonym for Load configuration on the Results Manager toolbar, and Ctrl+L. See Results Manager - Configurations.

 File » Exit

Exits the Results Manager. 

Figure 10. Results Manager Options menu

Opens the Transforms window, where you can create, edit and delete data transforms. Synonym for Set up your data transforms and Ctrl+Shift+T.  See Transforms.

Figure 11. Results Manager Help menu

Launches your browser with a URL to the eWater support site (Uservoice).

Launches your browser with a URL to the Results Manager section of this documentation.

Opens the Hot Key Window, which lists keyboard shortcuts and what they do in Results Manager. See Results Manager - Hot keys

Opens a dialog containing product and license information

Toolbars

Toolbars in the main window offer shortcuts to their equivalent menu commands.

Figure 12. Chart toolbar (Charts - Chart toolbar)


Drag (Shift)

When selected, allows you to drag a result from one chart onto another chart.

Pan

When selected, you can click and drag in the chart area to pan around the chart. This is particularly useful when examining a particular area of a chart using the zoom function.

Lasso Zoom

When selected, you can click and drag on the chart area to zoom in on that area. This is used in conjunction with Zoom Control.

Zoom Control

A pop-up menu affecting the zooming behaviour of Lasso Zoom.

Logarithmic graph

Recomputes the Y-axis of the graph for different logarithmic scales.

Toggle gridlines

A pop-up menu affecting the behaviour of grid lines.

Hint

Toggles display for the x and y coordinates of data points (also called tracing points). 

Units

A pop-up menu allowing you to change the display of the Y-axis to different, commensurate units.

Chart type

A pop-up menu that allows you to change the chart type. See Graph Types

Hide/show legend

Toggles display of the legend.

Toggle preview chart

Toggles display of the preview area.

Filter for overlapping data in multiple series

For custom charts, toggles display of overlapping data between two or more time series. 

Edit graph properties

Opens the Chart Settings dialog where various chart properties can be configured (eg. line colour, font size). See Charts - Chart settings.

Save

A pop-up menu where you can save the chart as an image (*.png file), as a data file (*.res.csv format), or as a full vector graphic (*.xps format).

Copy to clipboard

Exports the chart to the clipboard, in a vector format compatible with Microsoft Word. 

Print

Opens the print dialog so that you can print the chart. 

Figure 13. Data sources toolbar (Specifying data inputs - Data Sources Explorer)

New Data Source

Creates a new data source, using either the output of a scenario (Scenario Data Source…) or a time-series file (File Data Source…).

New Folder

Creates a new folder

Expand All

Expands the file hierarchy

Collapse All

Collapses the file hierarchy

Reload all time series

Reloads all time series when Reload on Run is selected

Sets if a failed "Reload on run" will stop the current run

Works in conjunction with Reload on run to determine if source data will cause scenario run failure.

Figure 14. Date ranges toolbar (Types of functions and variables - Function date ranges)

New date range

Creates a new date range of type as selected.

Filters out all default date ranges

Toggles view of all default date ranges. 

Figure 15. File toolbar (User Interface - Main screen)


New Scenario

Creates a new, empty scenario. Synonym for both File » New » Scenario… and New Scenario on the Project Explorer toolbar. Projects and scenarios - Scenarios.


Open Project

Opens an existing project. Synonym for File » Open….


Save Project

Saves the current project, overwriting the existing file. Synonym for File » Save. Implies File » Save As… if the project has never been saved.

Figure 16. Function editor toolbar (Functions - Function Editor)

This comprises of the text management toolbar, suffixed by additional icons.

Add/Edit Note

Allows you to add a new note, or edit an existing one for the function. See User Interface - About notes.

Insert built-in function (Ctrl+Space)

A pop-up menu allowing you to insert a built-in function. Synonym for Ctrl+Space. See Available functions, operators, variables and date ranges - Functions.

Figure 17. Function manager toolbar (Functions - Function Manager)

New variable

Creates a new function or variable of the type selected.

New folder

Creates a new folder in the function tree.

Expand All

Expands all items in the function tree.

Collapse All

Collapses all items in the function tree.

Edit functions…

Opens the Function Editor.

Filters items shown in tree

Opens the drop-down Filter menu, which toggles the display in the function tree of function and variables by their type and/or their use. Note that selections are also affected by text entered into the Function Manager search bar. 

Delete all unused

Deletes all unused functions and variables in the function tree that also match the current filter options and text entered into the search bar. Unused items that meet the selection criteria, folders that contain only unused items, and empty folders will also be deleted. Built-in variables and custom functions will not be deleted. This button is only enabled when Unused functions and variables is selected from the Filter menu.

Show function evaluation tree

Opens the Function Editor and displays the function evaluation tree for the selected function. This button is only enabled when a function is selected in the function tree. See Functions - Usages and References.

Show all function and variable usages

 Displays the usages of all function and variables in the function tree. See Usages and References.

Figure 18. Geographic editor toolbar (Geographic Editor)

Print

Opens the Print preview dialog allowing you to save the section of the schematic that is currently visible in the Geographic editor as a pdf.

Save as image

Saves the section of the schematic that is currently visible in the Geographic Editor as a *.jpg. 

Track

When enabled, the Geographic Editor window will scroll to bring into view any node or link that you select in the Project Hierarchy. You can use this feature to locate components in large models.

Note/Error icons

Toggles the view of any notes and/or errors that are present in the Geographic Editor. See User Interface - About notes.

Node labels

Toggles the view of node names in the Geographic Editor.

Link labels

Toggles the view of link names in the Geographic Editor.

Current zoom

Displays the current zoom.

Zoom in

Zooms in on the model in the Geographic Editor.

Zoom out 

Zooms out on the model in the Geographic Editor.

Fit to window

Fits the entire model horizontally and vertically in the geographic view.


Figure 19. Scenario Input Sets toolbar (Scenario Input sets)

This comprises of the text management toolbar suffixed with additional icons.


Insert scenario base nodes

Provides a list of available base path elements (scenario-dependent).

Insert units

Provides a list of available units (not scenario-dependent).

Apply values to scenario immediately

Override any other values specified for the same parameter elsewhere in Source for all scenario runs with the values specified in the manual parameter set editor. If disabled, the values take precedence for a single scenario run only. 


Figure 20. Layer manager toolbar (User Interface - Layer Manager)

Add layer

Add a new layer to the geographic view.

Move layer up

Moves the layer selected in the Layer Manager higher up in the layer appearance order.

Move layer down

Moves the layer selected in the Layer Manager lower down in the layer appearance order.

Remove Layer

Removes the layer currently selected in the Layer Manager from the geographic view.

Figure 21. Maps toolbar (Maps)

Hide map

Hides the map.

Maps

Shows a background map image with nodes overlaid.

Satellite

Shows a background satellite image with nodes overlaid.

Hyrbid

Shows a combined map and satellite image with nodes overlaid.

Fit to window

Zooms the map to fit the entire model horizontally and vertically in the map view.


Figure 22. Ordering toolbar

Configure Ordering

A pop-up menu with two options:

Figure 23. Project toolbar (User Interface - Main screen)

Project Explorer

Toggles whether the Project Explorer is visible on screen. Synonym for View » Project Explorer. See User Interface - Project Explorer.


Recording Manager

Toggles whether the Recording Manager is visible on screen. Synonym for View » Recording Manager. See Recording Manager.


Log Reporter

Toggles whether the Log Reporter is visible on screen. Synonym for View » Log Reporter. See Running Scenarios - Using the Log Reporter.



Figure 24. Project Explorer toolbar (User Interface - Project Explorer)


New Scenario

Attaches a new, empty scenario to the current project. Synonym for both File » New » Scenario… and New Scenario on the File toolbar. The available scenario options are:

See Projects and scenarios - Scenarios.

Copy Scenario

Makes a copy of (clones) the scenario that is selected in the Project Hierarchy. You are prompted to select a new name for the copied scenario. The new scenario will be a duplicate of the original at the time of the copy. All scenario names must be unique. See Projects and scenarios - Copying a scenario.

Delete Scenario

Removes the scenario that is selected in the Project Hierarchy. You are prompted to confirm the deletion. Deletions cannot be undone.


Recording Options

Allows you to change the state of all recordable parameters for the group or individual model element that is selected in the Project Hierarchy. The choices are:

See Running scenarios - Recording parameters.

Sort Categorised

Sorts the components of each scenario according to the type of component (eg. all links sort together, all nodes sort together, etc) and, within each component grouping, according to component subtype (eg. all Inflow nodes sort together).

Sort Alphabetical

Sorts the components of each scenario into alphabetical order according to the names of the components in your scenario.


View Type

This pop-up menu offers three choices:

Figure 25. Quick View toolbar (Charts - Quick View toolbar)

Allows you to apply either a date range filter or a repeating range filter to all results in the current chart, and you can also apply an aggregator.

Figure 26. Recording manager toolbar (Recording Manager)

Save Run Results

Exports time-series data from the currently-selected run to either a * .csv or tab-separated-value file.

Open Run Results in Excel

Exports the collected results data to Excel as a single time-aligned spreadsheet. The left-most column of the spreadsheet contains a time-stamp. Each of the remaining columns contains observations from one of your recordable parameters, in the same order as the results appear in the Recording Manager.

Open Run Results

Not enabled.

Delete Run Results

Clears the currently selected run. You are not prompted to confirm the action and it can not be undone.

Sort Run Results

This button lists the run results based on the network run order – leaf nodes to outlet node. Note that this is the default order of run results. It can be used to reset the results after other sorting methods (such as column headings) have been used. 

Figure 27. Scenario toolbar (Main screen)

Geographic Editor

Toggles the state of the Geographic Editor tab. Synonym for View » Geographic Editor.  See Geographic Editor.

Layer manager

Toggles the state of the Layer Manager window. Synonym for View » Layer Manager. See User Interface - Layer Manager.

Map

Toggles the state of the Map tab. Synonym for View » Map. See Maps.

Node palette

Toggles the state of the Node Palette. Synonym for View » Node Palette. See Nodes and Links.

Schematic Editor

Toggles the state of the Schematic Editor tab. Synonym for View » Schematic Editor. See Schematic Editor.

Tabular Editor

Toggles the state of the Tabular Editor tab. Synonym for View » Tabular Editor. See Tabular Editor.

Location Control

Toggles the state of the Location Control dockable window. Synonym for View » Location Control. See Maps - Location Control.

Data Sources

Toggles the state of the Data Sources dockable window. Synonym for View » Data Sources. See Specifying data inputs - Data Sources Explorer.

Function manager

Toggles the state of the Function manager dockable window. Synonym for View » Function manager. See Functions - Function Manager.

Figure 28. Schematic editor toolbar (Schematic Editor)

Enable connecting link to a different node

Toggling on allows you to disconnect the end of a link from the node to which it is attached, and then re-connect that link to another node. You can use this feature to insert new nodes into a schematic without losing the configuration of existing links.

Straight Lines

Toggles the representation of links to straight lines from the default of orthogonal (elbow) line.

Note/Error icons

Toggles the view of any notes and/or errors that are present in the Schematic Editor.

Node Labels

Toggles view whether the names of nodes are shown in the Schematic Editor. Source defaults to displaying node names.

Link Labels

This button controls whether the names of links are shown in the Schematic Editor. Source defaults to displaying link names.

Track (Schematic Editor toolbar)

When enabled, the Schematic Editor window will scroll to bring into view any node or link that you select in the Project Hierarchy. You can use this feature to locate components in large models. 

Overview Panel

Toggles the display of the Overview Panel in the Schematic Editor. The default state of this control is off. You can use the Overview Panel to obtain a thumbnail view of your entire schematic.

Pan

When enabled, clicking and holding on any part of the drawing surface in the Schematic Editor moves the entire drawing surface. This is an alternative to using the scrollbars.

Tool tips

A pop-up menu containing three options:

Show/hide water user and bulk licensing links

Toggles view of links that enter and exit the water user and bulk licensing nodes.

Display Grid

Controls whether the Schematic Editor displays a grid on the drawing canvas.


Snap to Grid

Controls whether nodes are aligned with the underlying grid in the Schematic Editor.


Set Grid Size

The value in this field determines the frequency of grid lines in the Schematic Editor. The units are in pixels.


Print

Opens the Print preview dialog allowing you to save the schematic in the Schematic Editor as a pdf. The entire schematic is scaled to fit on a single A4 page in portrait mode.


Save as Image

Saves the entire schematic in the Schematic Editor as a *.jpg.

Current zoom

Displays the zoom.

Zoom in

Zoom into the model in the Schematic Editor. Synonym for Ctrl +.

Zoom out

This button allows you to zoom out of the model in the Schematic Editor. Synonym for Ctrl -.

Fit to width

Fits the entire model horizontally in the Schematic Editor window.

Fit to window

Fits the entire model both horizontally and vertically in the Schematic Editor window.

Figure 29. Simulation toolbar (Running a scenario)

Select Analysis Type

Use drop-down menu to choose the desired analysis type for the model run. See Configuring Scenarios and Forecasting and Operations.

Configure

Opens a configuration window where you can set parameters to control the run (eg. date range, scenario input sets). The configuration window shown depends on the analysis type selected in the Simulation toolbar. Synonym for Run » Configure…. See Configuring Scenarios and Forecasting and Operations.

Run

Performs the selected analysis. Synonym for Run » Run on the Simulation toolbar. See Configuring Scenarios and Forecasting and Operations.


Figure 30. Statistics toolbar (Recording Manager)

Note: This toolbar is found on the Statistics tab of some results accessed through the Recording Manager. Equivalent options are accessed from the Period Type drop-down on the Statistics tab of Results Manager, see Chart Statistics

Monthly

Shows the statistics for each month of the year in the period run.

Yearly

Shows the statistics for each year in the period run.

Month by Year

Shows the individual statistics for every month of every year in the period run.

Total

Provides statistical data for the entire period run.

Full

Shows statistics for all data in the chart.

Windowed

Shows statistics for a specified range in the chart.


Figure 31. Text management toolbar

This is a generic toolbar used specifically for management of text input. It is present in the Scenario Input Sets dialog and Function Editor.


Open

Opens an existing text file from your specified location on the computer.

Save

Saves the text to your computer as a text file.

Cut

Cuts the selected text and places it in your computer's clipboard

Copy

Copies the selected text to your computer's clipboard.

Paste

Pastes the selected text. Enabled after either a Cut or Copy.

Delete

Deletes the selected text.

Undo

Undoes the previous action.

Redo

Enabled after the Undo action. Re-does the Undo action.

Word wrap

Wraps the text in the main panel to make it entirely visible on a single screen.

Show line numbers

Displays the line number in front of the line.

Show end of line

Displays an end of line character.

Toolbars in the Results Manager

Figure 32. Results Manager toolbar


Load a folder of Result Files (*.res.csv)

Loads all result files (*.res.csv) in the specified folder into Results Manager. Files in sub-folders are not loaded, nor are other time series. Synonym for File » Load Results Files and Ctrl+R. See Results Manager - Loading Results.

Load a time series

Loads any time series file type compatible with Source into Results Manager (refer to complete list of Data file formats). Multiple files can be selected and imported at once. Synonym for File » Load times series and Ctrl+O. See Results Manager - Loading Results.

Save configuration

Saves the current configuration of Results Manager to a configuration file (*.dora). Synonym for File » Save Configuration and Ctrl+S. See Results Manager - Configurations.

Load configuration

Loads a previously saved configuration file (*.dora) into Results Manager. Synonym for File » Load Configuration and Ctrl+L. See Results Manager - Configurations.

Go to a result in the tree

Opens a text box where you can search the results in the currently active scenario using the wild card * to represent any character. See Results Manager - Searching for results.

Set up your data transforms

Opens the Transforms window, where you can create, edit and delete data transforms. Synonym for Options » Transforms and Ctrl+Shift+T.  See Transforms.

Figure 33. Transforms toolbar (Transforms)


Add Transform type

Creates a new transform (or range filter) of type:

Remove transform

Deletes the selected transform